2017 June Release

Using EclipsePermanent link for this heading

Eclipse can be downloaded free of charge from the https://www.eclipse.org/ web site and the Java Development Kit can be obtained from the http://www.oracle.com web site.

Eclipse uses so-called features to package plug-ins and to allow for full integration with the Eclipse platform. Fabasoft app.ducx provides a feature that must be installed before it can be used with Eclipse.

Installing the Fabasoft app.ducx feature using the Update SitePermanent link for this heading

You can install the Fabasoft app.ducx feature by opening the “Help” menu and clicking “Install New Software”. Click “Add”. In the following dialog input an individual name (e.g. “app.ducx Update Site”) and the location “http://update.appducx.com”.

Figure 2: Specifying a new update site in Eclipse

Select the “Fabasoft app.ducx” feature and click “Next”. Click “Finish”.

Note:

  • If your Eclipse installation does not meet all prerequisites, missing features are downloaded from the Eclipse Update Site. Make sure that thise site is activated in the “Available Software Sites”.
  • If you have recurring problems updating the Fabasoft app.ducx feature you can try to delete following files:
    C:\Users\<username>\.eclipse\org.eclipse.oomph.p2\cache\http___update.appducx.com*
    C:\Users\<username>\.eclipse\org.eclipse.oomph.p2\cache\http___update.apptest.com*

Installing the Fabasoft app.ducx feature using the archivePermanent link for this heading

You can also install the Fabasoft app.ducx feature using an archive. Open the add dialog in the install wizard. In the following dialog click “Archive”. Select the Fabasoft app.ducx archive provided on the Fabasoft app.ducx installation media (Plugins\ducx.eclipse.updatesite.zip) and click “OK”.

Select the “Fabasoft app.ducx” feature and click “Next”. Click “Finish”.

Note: If your Eclipse installation does not meet all prerequisites, missing features are downloaded from the Internet. Make sure that your proxy server (if necessary) is configured correctly in Eclipse (“Window” > “Preferences” > “General” > “Network Connections”) and that you are connected to the Internet.

Updating the Fabasoft app.ducx featurePermanent link for this heading

Every time the Fabasoft Folio Domain used for development is updated, the Fabasoft app.ducx feature for Eclipse has to be updated, too. The update process is the same as described in chapter “Installing the Fabasoft app.ducx feature using the Update Site”.

Note: How to update Fabasoft app.ducx projects for a new software release is described in chapter “Updating Fabasoft app.ducx projects using Eclipse”.

Improving the performance of the Fabasoft app.ducx compilerPermanent link for this heading

To improve the performance of the Fabasoft app.ducx compiler, edit the eclipse.ini file found in the Eclipse installation folder and assign sufficient memory to the Java virtual machine by setting the -Xms and -Xmx parameters to an adequate value (e.g. “768m” or “1g” for the 32-bit edition of Eclipse, “2048m” or higher for the 64-bit edition).

Example

-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
-vmargs
-Xms256m
-Xmx2048m

Using Fabasoft app.ducx with an older Fabasoft Folio DomainPermanent link for this heading

Fabasoft Folio DomainPermanent link for this heading

Do not install the current version of Fabasoft app.ducx. Let the Fabasoft Folio Domain as it is.

ClientPermanent link for this heading

Install or update the current Fabasoft app.ducx plug-in for Eclipse. The app.ducx projects are compiled for the version and software edition of the Fabasoft Folio Domain.

Note:

  • If the Fabasoft Folio Domain has the version 2008 Production or 8.0 Production, the target version for which the projects should be compiled has to be set manually in the .ducxproject file: <ns:VersionTarget>VERSION8</ns:VersionTarget>.
  • Highlighting of keywords in the development environment is based on the current release.