2017 June Release

Working with Fabasoft app.ducx projects using EclipsePermanent link for this heading

Running a Fabasoft app.ducx projectPermanent link for this heading

You have to create a new launch configuration before you can run a Fabasoft app.ducx project in Eclipse. To do so, click Run Configurations on the Run menu. This will bring up the dialog box shown in the next figure.

Figure 10: Creating a new launch configuration in Eclipse

In this dialog box, click the “New launch configuration symbol and enter a Name for the new launch configuration. In addition to this, select the Project by clicking Choose. Click Apply to save your settings, and Run to run the Fabasoft app.ducx project.

Once a Fabasoft app.ducx launch configuration has been created, you can select the existing launch configuration on the Run as menu to run the Fabasoft app.ducx project.

Modified project files may be saved automatically depending on the launch configuration of Eclipse.

Note: A Fabasoft app.ducx project is always compiled for the current version and software edition of the Fabasoft Folio Developer Domain.

Adding a software component referencePermanent link for this heading

Whenever you either explicitly or implicitly reuse parts of the functionality provided by another software component, you have to add a reference to this software component.

To add a software component to your Fabasoft app.ducx project in Eclipse, select Add Reference from the Software Component References context menu in the Eclipse Project Explorer. In the dialog box shown in the next figure, select the software component to add. You may also select more than one software component.

Figure 11: Adding a reference to a software component

Adding a reference to a software component triggers a web service call, which downloads required information about this software component to the local Fabasoft app.ducx cache on your computer. The cached information is then used by the Fabasoft app.ducx compiler and for providing context-sensitive help.

All added software components will be inserted in the list of prerequisite components of the software component when the project is built.

You can also remove references to unused software components at any time.

Adding a source filePermanent link for this heading

In Eclipse, you can add new source files to an existing Fabasoft app.ducx project at any time by selecting the type of source file you would like to add from the New context menu of your Fabasoft app.ducx project in the Eclipse Project Explorer (see next figure).

Figure 12: Adding a new source file to a Fabasoft app.ducx project

Adding resourcesPermanent link for this heading

You can add resources – such as symbols – to a Fabasoft app.ducx project. It is recommended to add all resources to the resources folder. Symbols should be added to the symbols subfolder.

In Eclipse, a new symbol can be added to your Fabasoft app.ducx project by clicking New on the context menu of the Eclipse Project Explorer.

To add an existing resource, just drag the file into the desired folder of your Fabasoft app.ducx project. You may also select Import on the context menu of the target folder in the Eclipse Project Explorer.

Exporting a Fabasoft app.ducx projectPermanent link for this heading

Exporting a Fabasoft app.ducx project allows you to distribute your project to customers. A Fabasoft app.ducx project represents a single software component. Related software components can be encapsulated in a software product. Several software products build up a software edition. A software edition is a complete product like Fabasoft Folio. To customize a software edition depending on customer wishes is done with a software solution.

Software products, software editions and software solutions are defined as instances within a Fabasoft app.ducx project. For more information how to define such instances see chapter “Defining proprietary types and property classes”.

Exporting software componentsPermanent link for this heading

In Eclipse, open the “File” menu and click “Export”. Navigate to “Fabasoft app.ducx” > “Extract Component” to export your Fabasoft app.ducx project to a Fabasoft Folio container file (with a .coo extension) that can be installed in another Fabasoft Folio Domain by loading it using the Fabasoft Folio Server Management tool.

Figure 13: Exporting a Fabasoft app.ducx project

Exporting software products, software editions and software solutionsPermanent link for this heading

In Eclipse, open the “File” menu and click “Export”. Navigate to “Fabasoft app.ducx” > “Extract Solution” to export a software product, software edition or software solution of your Fabasoft app.ducx project.

Managing address rangesPermanent link for this heading

The address range file and the defined address ranges can be managed in the Fabasoft app.ducx project settings. The used address range file can be selected, new address range files can be created and additional address ranges can get requested.

Note: For access to the configured Address Service it may be necessary to use an application password.

Figure 14: Managing address ranges

Attention:

  • Make sure that there is an address range file for every developer working concurrently on the project. Doing so prevents later merging problems.

Managing addressesPermanent link for this heading

In some rare cases it may be useful to change the automatically assigned object addresses. For this purpose an object address editor is available. It can be accessed via the “Address Assignment” entry of a project in the Eclipse Project Explorer.

Attention:

  • We recommend changing object addresses only if it is absolutely necessary (e.g. if two developer have accidently used the same address range).

Defining a friend componentPermanent link for this heading

In the Fabasoft app.ducx project settings a list of friend component references can be provided for your component. The friend components will have access to all the private entities of your component.

Steps to make a component APPDUCXSAMPLEFRIEND@200.200 friend of a component APPDUCXSAMPLE@200.200:

  • In the Fabasoft app.ducx project settings of APPDUCXSAMPLE@200.200 add APPDUCXSAMPLEFRIEND@200.200 to the “Friend Components” list.
  • Compile and upload APPDUCXSAMPLE@200.200
  • In project APPDUCXSAMPLEFRIEND@200.200 add or update reference APPDUCXSAMPLE@200.200.

Adding additional contentsPermanent link for this heading

Additional contents may be specified within Fabasoft app.ducx project settings. It is not necessary to specify contents like reference documentation, coverage metadata, used jars or generated jars. It is solely for additional contents, e.g. help contents (Compiled Help Files) or contents for a specific platform, e.g. Windows X64 only. These contents will be part of your Software Component.

Contents are simply added by dropping a bunch of files from the filesystem. Additional properties may be set after drop. Basename is initially constructed from the basename of the file, Type is CCT_NORMAL by default. The basename may be changed.

Fabasoft app.ducx tries to identify available variables. The longest match is used. Variables include environment variables and variables available within in Eclipse.

Note: When using a build process out of eclipse, Eclipse variables might not be available.

Note: This Page is currently not available for Fabasoft Cloud Apps.

Working together/using a version control systemPermanent link for this heading

For Fabasoft app.ducx projects it is also possible to use a version control system like Subversion or git very easily.

Following files and directories of a Fabasoft app.ducx project have to be checked in:

  • .ranges (folder)
    Note: All files except the .mergedducxranges.xml are required for building your projects.
  • .references (folder)
    Note: Only *.xml (cache, solutions, languages) are required for building your projects. For convenience *.refdoc may be checked in to get quick tips in the editor without updating the references.
  • .references/lib (folder)
    Note: Only those JARs (e.g. AXIS2 runtime JARs) have to be checked in that have references in the .classpath file.
  • .settings (folder)
    Note: The .settings folder contains also developer specific settings for the project (com.fabasoft.ducx.prefs). Do not check in or share com.fabasoft.ducx.prefs but keep it in order to not lose personal settings like the name of the personal address range file.
  • resources (folder)
  • src (folder)
  • .classpath
  • .ducxproject
  • .project
  • *.ducx-*

Note: Some of these directories and files are optional. Some older projects use .ducxranges.* files instead of the .ranges folder. These can be replaced with the range files of the .ranges folder.

Several developers may work on a single project. In a project the address ranges of each developer should be stored in a different file. During development only the address range file that belongs to the developer gets changed. It is essential to check in the address range file together with the source files.

Generally in Java projects version control files like .svn should be excluded from the build process. Open the properties of the project and navigate to “Java Build Path”. On the “Source” tab edit the “Excluded” entry and enter e.g. following line **/.svn;**/.svn/* as exclusion pattern.

Customize font and colorsPermanent link for this heading

App.ducx provides customizable font and background color properties for the multilingual strings and address assignment editor,

The font and the background color can be defined in the Eclipse preferences (“Window” > “Preferences” > “General” > “Appearance” > “Colors and Fonts”> “app.ducx”).

The font of the app.ducx language editors can be customized by changing the value of “Text Font” in the Eclipse preferences (“Window” > “Preferences” > “General” > “Appearance” > “Colors and Fonts”> “Basic”).

Fabasoft app.ducx BuildersPermanent link for this heading

Running app.ducx in Eclipse requires the setting “Project” > “Build Automatically” to be enabled, so that cross referencing between different source code sections can be established. This setting will be automatically enabled once after installing the Fabasoft app.ducx feature.

Generating output of a Fabasoft app.ducx project is done by the Fabasoft app.ducx builder. This builder can be configured to run on each automatically triggered build by the Eclipse Platform. The corresponding setting (“Generate COO-file on automatic build”) has to be set in each project’s preferences. By default this setting is disabled because generating output is not necessary on each save operation in Eclipse.

  • Note: This setting can only be enabled in non-cloud app projects.

Fabasoft app.ducx projects using Java implementations also provide a java archive which contains the implementations of the dedicated actions and usecases. This archive is created by a separate builder which runs only when the project is uploaded to the specified Fabasoft Folio domain.

Submitting Feedback regarding Fabasoft app.ducxPermanent link for this heading

Fabasoft app.ducx provides a possibility to submit a feedback. A button is placed in the main tool bar and with a click on this button you can enter text for your feedback. Additionally you can specify which projects you want to submit and if you want to include a screenshot.